Configuring OS timezone

Hi folks,

British Summer Time has rolled around and all of the clocks on my Fullscreen Browser-based dashboards are an hour out of sync!

Is there any way to configure the system timezone for all of my devices?


Oh. I didn’t consider how timezones affect the fullscreen browser at all. The OS itself isn’t timezone aware and always uses UTC. I guess that is then also what the browser uses as nothing is configured before it starts. I can look into that and see if it’s possible to make that a setup option.

1 Like

I’ve added support. There’s now a new timezone dropdown you can use. Can you update your browser package using the Check for updates button and test if that works for you?

Note that changing the setting won’t restart the browser, so you might either quickly switch to another setup or reboot the Pi when you change the timezone value.


Works exactly as expected - thank you!

3 posts were split to a new topic: Reception screen language support