info-beamer

4K HEVC slow video playback 90 degree rotation

Strugling with approximately 10-20% slower playback speed with my 4K portrait video when screen rotation is set to 90 degree in the info beamer web setup. Plays fine when not rotated (though then the video is not filling much of the screen)

I am using the HD image / video package and a Pi 4 4GB. This is a HEVC /h.265 video (2160 x 3840 / portrait, 30 fps, 8 bit). Encoded in Davinci Resolve using the Nvidia encoder, constant bitrate, high quality, 7000 Kb/s.

Using 90 degree screen rotation in the info beamer web setup. The 1 minute 13 seconds video is about 65 MB.

Have just installed a fresh stable release image to the SD card. Pi in high performance mode.

I am able to log into the device console from the info beamer web device page, and it responds to commands.

Any tips on overcoming the slowdown will be appreciated!

Interesting. It might well be that rotating 4K content is too much for the Pi. The video_render part of the hardware decoding process is doing extra work when rotating and it seems 4K is over the limit of what’s possible. I’ve asked about this in the Raspberry Pi forums before (see here). I fear the only option for 4K content is to use pre-rotated videos. It might be that 4K at 24 or 25Hz might be just the limit :-\

Thanks for the tip regarding fps. Rendered in 24 fps now, and the slowdown is reduced to about 4%. That’s acceptable :slight_smile:

Thanks for the update. If that works for you: great. One other thing you might try is to reduce the overall refresh rate of the display from 60Hz to 50Hz using the device settings. This might free up some resources. Maybe that’ll get rid of the slowdown?

I don’t think there’s anything else (despite rotating the video beforehand) you can do on the Pi.

info-beamer - Digital Signage for the Raspberry Pi community forum - Imprint