Bootloop error performance

We have are having troubles with players that were working. We changed the online setting performance from powersave to performance and since then the players are in a bootloop. I’ve already tried changing it manually now in the “Scaling Governor” file but still no result. We would like to solve it without recreating the player :slight_smile:

Uff. That’s a very early reboot - after 0.8 seconds into booting the kernel. I suspect this is something different. At that point the performance setting isn’t even applied yet. That happens a bit later (~3-4 seconds in). Judging by the backtrace at the very top, there seems to be some problem with mounting the root file system. You can follow the steps here:

At that point that would most likely be the initramfs. I suspect that this got damaged somehow. Can you verify that? Mount the first partition of the SD card (be sure it’s the first: After updating/applying configs, there’s two similar looking partitions due to A/B booting) and then run sha1sum:

$ sha1sum /path/to/sd/initramfs.gz
4f5085069bb8cdd29398db626ee1d8cb7bdcf61f  /path/to/sd/initramfs.gz

I would suspect that you get a different checksum. Can you try that?

You really have to guide me trough this because I don’t know where to start. The code you were sending me how do I use it etc… Your explanation just sounds chinese for me :sweat_smile:

Can you put the SD card into any other machine? Windows / MacOS? The have a look at the SD card. There should be a file named initramfs.gz. If you see two drives, initramfs.gz should be one both of them. To make things easier: can you send them by email to

Done! Mail is named “Boot loop error performance” from the email adress:

To keep this post updated in case a similar issue shows up in the future and to inform other users: The problem was that inside the userconfig.txt an incompatible boot settings (more precisely the initramfs line) was specified. This resulted in the kernel not finding the initramfs file and panicking after updating to a later OS release version.

info-beamer hosted OS doesn’t touch the userconfig.txt file and users have to be careful what kind of configuration they place there. Those settings become active before the kernel boots or influence how the boot process works. If the kernel fails to boot due to an incorrect setting, the usual fallback mechanism won’t work as that depends on at least the kernel working correctly. The general hint would be “Be careful what you put in /config/userconfig.txt” and better contact support beforehand.

The documentation on that setting will be updated in the near future with a clear warning regarding custom settings.

1 Like