Changing browser language / setting the locale

Hey there,

I´m displaying a website with the fullscreen browser package.
The website is available in english and german, but is beeing displayed in english.
I suspect the locale beeing not set correct.
But I´m having trouble setting the locale of the PI since there is no raspi -config.

Any advise?

Right now I guess the browser takes the default Accept-Language setting, which is probably en-US or similar. I’ll have a look to see how that might be configured. Stay tuned.

1 Like

here is a thread with a fork of the browser package that can send custom headers to websites.

you could try to override the “Accept-Language” header with something like “de-DE,de;q=0.9,en-US;q=0.8,en;q=0.7”


The browser package has been updated to include an option to specify the preferred language. Within your list of packages, click the dropdown next to the browser package and select “Check for updates”. This will update to the latest release. In a browser setup’s configuration there is now the new option to select a language.

If a language is missing, let me know.

1 Like

Thanks for the quick Update for all of us out here.
Best regards!