info-beamer

Disable internal WiFi on Pi3b+

Hi,

I am trying to use an external RTL8188 based USB dongle as I need an external antenna but I can’t find any way to disable the on-board WiFi?

Is it possible to do this?

Thanks

Phil

As a follow-up to this, I have managed to disable the Internal wifi by adding pi3-disable-wifi to config.txt but the external USB I am using (Edimax EW-7811Un V2) doesn’t seem to work. I assume it needs the V1 model?

Sorry about the delayed response. The notifications about new topics seems to have stopped.

[…] pi3-disable-wifi to config.txt

Correct. That will disable the internal WiFi. But you should add the line to /config/userconfig.txt as /config.txt is managed by info-beamer OS and will be reverted if changed.

Unfortunately this is correct. The V2 uses a different chipset that isn’t supported at the moment.

  1. make sure you have the latest firmware updates on your Pi.

  2. run the Pi config (raspi-config I believe). It will start a GUI that will allow you to change settings on it. One of the settings is to enable/disable the wifi (as I have wifi disabled on a couple of my Pis since I use POE with them).

  3. test the wifi on the Pi. Is it better/worse at receiving a signal where it is going to be placed than the dongle is? Do you really need the dongle with the Pi? Perhaps you do, I do not know your environment, but if not; I would suggest just using the wifi on the Pi (it will make troubleshooting issues later easier).

Good Luck.

info-beamer - Digital Signage for the Raspberry Pi community forum - Imprint