Fullscreen Browser | Loading problem with disabled duration

Hi, we’ve encountered a problem with ‘Fullscreen Browser’ package. Setting ‘duration’ to ‘disable’ in the Content configuration tab, the web page doesn’t show up (it stuck on package loading logo). Everything works fine with the others duration values. Thanks for your help!

I guess the wording isn’t good in that case: Disabled means that the corresponding page isn’t displayed at all. I think that was some user request a while ago. There is no option to show a page forever, which I guess is what you want?

Hi, yes indeed it is what we want (Develop.iakta is a collegue of mine).

The bug though still remains for Disabled option.
Thanks anyway

1 Like

Not sure I would technically count that as a bug: The Disabled options means: Don’t show this item. If the resulting playlist is empty, nothing can be shown and the loading animation waits until the configuration changes to one more useful.

could there be a open for alway plays as if you just have a single url it will refresh every 10 minutes.

Sure. That’s possible, although I think that might be a bit risky. I would guess the use case for that is to load some kind of dashboard that auto-refreshes itself? In that case, what should happen if the initial page load doesn’t work for some reason? Like there’s some hiccup, the network was down or something like that. In that case, the browser just shows some error page indefinitely as there’s no real way to detect that.

Right now some external process forces a refresh after at most 10 minutes. So something temporary might break it for 10 minutes max. Ideas welcome.

Yes you are correct: it is not a bug :slight_smile:

Just recently came across this software and it is by far the best I’ve found by far. I was disappointed to have the same question regarding the duration only to find that theres no way of setting the url to always display without having a duration set. Reading your reason behind this, I understand. However the option would certainly be great to have in the sense that anyone who uses it set it at their own risk. I’d much rather to a quick refresh/reboot of the pi if it didn’t initially load rather than seeing a web page refresh every time for no reason. Is there a backend config setting we can set to change this?

I could add larger reload durations and maybe an infinite one.

info-beamer - Digital Signage for the Raspberry Pi community forum - Imprint