info-beamer

Gl setup not working? Trying to display a simple video file

Came across info-beamer when looking for a way to loop a seamless video with audio for a fundraising event for my kid’s school. Looked at info-beamer host and it works great, but I need to setup the device without internet - and hence am trying to roll my on on fresh Raspbian Buster install.

I’m trying to run a simple setup named “videoplayer” that plays a video file with the following .lua file:

    gl.setup(1920, 1080)
    local video = resource.load_video{
        file="GlitterBall_2020.mp4";
        audio=true;
        looped=true;
    }

    function node.render()
        video:draw(0, 0, WIDTH, HEIGHT)
    end

When I run the command:

$ INFOBEAMER_BLANK_MODE=layer ./info-beamer videoplayer

The program runs and I get a black screen, but video doesn’t play. When I quit, I see the following:

main.c] root node is videoplayer
[main.c] loading nodes
[videoplayer] update +GlitterBall_2020.mp4 (search)
[videoplayer] update +videoplayer.lua (search)
[main.c] initialization completed
[videoplayer] node error: cannot render node 'videoplayer'
You have to setup the node by calling gl.setup first
See https://info-beamer.com/doc/info-beamer#gl.setup

When I run the sample setup “image” though, I get the expected results and see the image and it has the same gl.setup code…So, what am I doing wrong? Can anyone tell me how to start troubleshooting this?

You basically have everything all right, except one minor details: in the videoplayer directory, the Lua code has to be in the file node.lua, not videoplayer.lua.

PS: I took the liberty of reformatting your code so it gets code-highlighted and is a bit easier to read.

Ohhhhh!!! so all setups require “node.lua” as the file name…I get it.

Thank you!!!

info-beamer - Digital Signage for the Raspberry Pi community forum - Imprint