Home Assistant dashboard autostart live camera entity

Hi all,
I have set up info-beamer Fullscreen Browser to show one of my Home Assistant dashboards, which includes a “Picture entity” card with a live camera.

The problem is that, the live stream does not start. I have already tried it on RPi 3 and 4, too.
Other cards are refreshing well.

Normally the stream “autostarts” in every browser. I think it may be a problem with the Chrome integration in info-beamer.

I have already tried different settings in home assistant (TCP, UDP connection to camera, RTSP and ONVIF, h264, h265, higher and lower resolutions).

Do you have any idea?

Can you check how the stream is implemented in the Home Assistant dashboard? I just took a peek at my dashboard using cheap ESPHome based cameras and they seem to update their stream using motion JPEG via Content-type: multipart/x-mixed-replace; boundary=--frameboundary.

I have just set up a dashboard containing only the picture entity card which we need.
The camera is an h264 RTSP stream directly from the camera.
(Also tried RTSP stream from the NVR, and ONVIF integraion).

I checked the Content-type for you, attached screenshots of developer tools.
It seems that loading of the “sample” picture (latest actual frame at page loading) of the camera works, but the live stream does not start.

I also checked other signage softwares if that helps.
The stream autostarts succesfully only in PiSig**ge. (Pi3, Pi4 too)
The stream does not start in Yodek, FullPgeOS and info-beamer.

(Useful snapshots deleted by moderator, just to be sure that none of the parameters shown in the image are important)

Thanks. I removed your images, as the Url is probably easy to guess if you try hard enough :slight_smile:

It looks like a HLS stream. Maybe this is due to autoplay for video restrictions. Of course those don’t really make sense for a browser without any manual input. I can check if that’s some setting I might be able to overwrite when starting chromium. I’ll try to release a new version of the browser package tomorrow.

1 Like

Thanks for looking into it. :grin:

I tried adding --autoplay-policy=no-user-gesture-required to the start arguments, but that still isn’t enough. I get none of the video tests on https://videojs.github.io/autoplay-tests/ to work. chrome://gpu suggest software decoding, but https://www.chromium.org/audio-video/ suggest that chromium maybe doesn’t support H264?

I tried to directly link the VP9 video from https://base-n.de/webm/VP9%20Sample.html and that does indeed play. What other codec options do you have?

This camera supports only h264.

And the only way to show camera in home assistant is to set up a picture entity card.

I can give you readonly access to the URL of my dashboard privately. You may want experiment with it.