Info-beamer-hosted - Sound drops after 15sec while playing 1080p /60fps video

Hello all,

For whatever reason we didn’t bump into this issue before but this is what we got sofar.
Our client uploaded a short MOV video that got nicely recognized by the system.
The video starts playing normally with sound but after 15 seconds the sound is killed, not just stops but you can hear that the system has issues playing it … the video gets displayed normally.
My first guess a bad video codding orso.
Downloaded the video and locally the video displays perfectly.
A positive result after a quick convert in HandBrake on setting General - Fast 1080p30 … the video is now working fine, downside is the dropping of the FPS from 60 to 30.
A quick recoding on some other settings resulted in the same … as long the video was only 30fps it was fine … switching this up to 60fps (or the professional proxy 1080p) resulted always in sound drop after roughly 15 seconds.

Is there a way the MOV (1080p/60fps) file can be recoded in a way that the fps can be above 30 fps ??

thanks in advance

If you can reproduce this problem with a short 60fps video, I might take a closer look to see what happens. Is that possible?

I think 45sec I really short

Could you send the asset id (you’ll find that if you click on the asset in the asset browser) to support?

infobeamer2, have you tried encoding in mp4 format?

We’ve used plenty of video files with audio and never had an issue, although I can’t actually remember if these were 30 or 60 fps.

Just a thought, what are your video output settings for your device?

Maybe. Although MP4 is only a container format that allows muxing of video/audio/subtitle or other streams within a single file. What might have happend is that the interleaving of audio/video spread out the audio parts too far.


If the AAVVV… line represents the MP4 file from start to end, and V/A are the individual audio/video packets in that file, if they are spread out like this, the audio buffer might run out of data while the video decoder outputs its frames. Although in that case the video should actually also stop playing. So it’s rather unlikely that this is the reason.

                 --> time
(file reader) 
   +->  [A,A,A,_,_,_,_,_,_,_] -- (decoder) --.
   |                                          >--- (audio/video output)
   '->  [V,V,V,V,V,V,V,V,V,V] -- (decoder) --'
          internal buffers

I’ll need to look at the file to see what’s going on.

To be honest Florian that’s over my head! but I’m sure you’re right :slightly_smiling_face:

File with the issue described :

Converting the file to mp4 with lower 30fps resolved the issue
Converting the file to mp4 with the same 60fps resulted in the same sound cutting after 15sec

I can reproduce the problem. Haven’t looked yet into what exactly cause it, but I’ve been able to fix it by applying a performance setting to the Pi. Go to the device page and select “Performance” instead of “Power Save”. This will reboot once and the Pi will be clocked higher after a reboot.

1 Like

It looks like it may be a performance related issue then?

I tried converting the original MOV file to MP4 using the default settings in Compressor ( Mac app ), what i noticed is that the default fps settings were 59.94fps, not 60fps.

I have the option to input any FPS value, but thought I’d try it at the preset and share it with you to see if the same issues persist.