info-beamer

Multicast Streamer setup with LKV373

I’m trying to setup an LKV373 to stream a roku or chromecast to my video wall, but am having trouble “receiving” any video when connecting everything via my switch.

I’ve also tried adding the LKV IP address directly and letting the multicaster package auto detect, but no dice with either approach.

I’ve tested the LKV, connecting the transmitter/receiver directly with a single ethernet cable - that’s the only way I’ve been able to successfully get anything to work (transmit video).

This is my current setup, below… anything I’m missing or misunderstood on the setup?

Current state:

  1. No video/blank-black screen on test screen 1
  2. LKV receiver can’t find anything (Searching for TX…, test screen 2)

Look good in theory. The way this is supposed to work is that the LKV is sending multicast packets The Pi should receive those and detect the LKV373 IP address from that. It then sends an HTTP configuration request to the LKV and sets it to unicast, so packets only end up on the Pi running the multicaster setup. It then sends another HTTP packet that configures the LKV encoding parameters. Once all that’s done, the Pi starts ffmpeg to receive the stream and the multicasts that to any other Pi in the network (and only the network: The screen ‘test screen 1’ is supposed to be blank in that case except for some status infos)

The reason this doesn’t work might be that your LKV is running a newer firmware release where this all works slightly different. I guess the only way to find out is to look at the log output while that’s all running.

Thank you Florian. I’m running my setup now and can leave it on, is there any debug/log info I can grab to help (or you want to check anything out on the system live)?

Activate the “Show remote terminal on device page” option on the account page, then open the multicaster device page and click on the connect button. You can then use the logread -f to read the live log file. I guess logread -f |grep service.root: should show you the streaming service logs only. I might take a look later, but can’t promise. If there a way for you to keep at least the LKV and the multicaster Pi running for longer?

I took a look but can’t see any obvious reason. The TX seems to do something, as packets do indeed arrive on the Pi and communication with the LKV also seems to work.

[hosted.py] going to restart when config is updated
received a stream packet from 192.168.10.89. no unicast configuration required
setting streaming parameters
config: http://192.168.10.89/dev/info.cgi?action=videoinfo&hdmi=y&cvbs=y&videoin_res=1920x1080_60P&videoin_frate=60&videoout_fhd=1&videoout_hd=0&videoout_brate_fhd=4000&videoout_brate_hd=4000&videoout_brate_sd=4000
parameters set. we should receive data now
ffmpeg version 4.0.2-static https://johnvansickle.com/ffmpeg/  Copyright (c) 2000-2018 the FFmpeg developers

But then ffmpeg is unable to detect any video in the received data. And I’ve no idea why. You might toy around with its configuration interface on http://192.168.10.89/iptv_info.html, switch back to multicast while the multicasting Pi is not powered and check if the data is viewable in VLC or similar.

I don’t think there’s an easy solution to this. It might well be that your device uses a different firmware than mine did a while ago. I’ve got most of my information from https://blog.danman.eu/new-version-of-lenkeng-hdmi-over-ip-extender-lkv373a/, so checking some comments there might also be useful.

I’m thinking this has to do HDCP encoding - will get a chance to do some more testing later today…

Oh. Didn’t think of that. You’re probably right given that’s it’s a Roku Box.

info-beamer - Digital Signage for the Raspberry Pi community forum - Imprint