info-beamer

Pi and HDMI output problem

hi to all,

i just bought new Pi4 8gb model and i want to use him like info screen in my shop.
i followed instructions for setup and everything went great.

on fist boot i dont get any picture on my TV ( i use my 3 years old tv like screen ), it just stays message " no signal "
i have tryed to write custom and standard image, also with Pi writer, but i get same problem.

maximal resolution which is supported by my TV is 1366*760 on 60 Hz.

if somebody can give me some advice i would be thankful.

cheers

Most likely that won’t help, but on the Pi4, did you use the correct HDMI output? It has two and you’ll have to use the one closest to the power connector. See Pi4 Device doesn't start (it’s the left one in the picture).

Did you get any signal at all from the Pi? What are the LEDs on the Pi doing? There are two of them. Is the red or green one on at all? Are they blinking in a pattern after you connect power?

What you can also try: Put the SD card back into another computer and create the file /config/userconfig.txt on the SD card. Add the following content:

hdmi_group=2
hdmi_mode=81

Then put the card back into the Pi and connect power again. This will explicitly set the mode 1366x768. Maybe that help?

Also hopping onto this- We have some TVs which seem to intermittently recognize the signal. These same players work fine on plenty of other display devices but on these commercial install TVs they seem to have some issues. Telemetry shows them dropping out after a few hours, and power and everything is completely secure and stable.

What do you mean by “dropping out”? They are completely offline? Is the screen blank at that point? Did you explicitly set a resolution or do you use auto-detection?

We’ve tried using auto-detect and a few different forced resolutions as well as changing the order in which things are powered on. It looks like with the telemetry, all 4 graphs drop to 0 and the screens display a “no signal” message, however the players are still online. All connections are solid and the power supplies are sufficient. We also tried rebooting a few times as well.

Are you sure you’re not using the power-saver package to shut down the displays? It sounds like the device is still reachable yet HDMI output is powered off. One immediate way I think that might happen is due to the power-saver package shutting down the displays. Can you check that? If not, can you contact hello@info-beamer.com and send the device’s serial if that happens again. I can take a look and hopefully see what’s going on.

Thanks Florian, sent a message yesterday

Answered. Post will be updated if there’s anything useful to add.

To the OP.

I think this may actually be an issue with the Info-Beamer OS not being recent enough for a Pi4 with 8GB RAM. I have two Pi4’s, one 4GB and one 8GB both of which work just fine with the latest Pi-OS (Raspbian 10).

I decided to try Info-Beamer (IB) on the 8GB Pi4 and like you ran it to problems with no display at all, whichever burn method I used. I then noticed that the activity LED (green LED) was flashing a sequence of pulses - 4 slow, 4 quick - whilst the red LED remained steady.

These series of pulses indicate an error which if you check on the RPi Org. site suggests an “unsupported board”, or probably more accurately an unsupported OS.

I then moved the SD-CARD to the 4GB Pi4 and the installer kicked off as it should and I now have a functioning system.

So, to cut a long story short I don’t believe the 8GB Pi4 is yet supported by IB.

1 Like

Interesting. To be honest, there’s no local 8GB model to test at the moment as I expected them to work similar to the 4GB model. Guess I was wrong. Ordered one now. Can you check if the testing version works out of the box? It has more recent firmware and eeprom files.

I’d love to help out but I’ve just repurposed the Pi4 8GB and so it’s no longer available. Sorry.

No worries. A test 8GB will arrive soon.

Can confirm that the default Pi4 8GB version doesn’t boot stable out of the box. Most likely reason is that the firmware files used in that release do not work with the EEPROM (version 2020-03-19) flashed on that 8GB model.

Installing testing works out of the box. Similarly if you then switch back to stable after installing testing it works as well, although you get error lines while booting and probably other side effects:

image

Guess it’s time to promote the current testing to stable now.

info-beamer - Digital Signage for the Raspberry Pi community forum - Imprint