info-beamer

Problems with videos on Pi4

Hi, I have some very short videos (1.5s each) which I want to play in a loop. I have had various issues.

  1. Originally they were h.264 files (1080x1920 portrait) and they didn’t play at all so I converted them to h.265 and they seem to play.

  2. If I try to play two videos simultaneously on a schedule (using both HDMI outputs of Pi4) then only one gets played, it seems quite random which one will be played!

  3. Sometimes when the video is playing it seems to speed-up and play at 2x speed!

I am evaluating info-beamer for a retail project and they would like to be able to display videos on both screens connected to the Pi4.

Thanks

Phil

The firmware in the current stable release of info-beamer has an issue playing 1080x1920 H264 videos. Can you switch over to testing by visiting the device page, clicking on Manage and selecting activate testing channel. This issue should be fixed there. The next stable release will be out soon. You can then switch back.

Regarding 2) / 3): The problem with H265 is, that at the moment it’s not possible to play two videos at the same time. Only one video decoder can only be used at any moment. This results in what you’re seeing: One of the two videos is starting and the other one is waiting for the decoder to be available again. It might then try to catch up.

Let me know if that helps.

That’s brilliant thanks. I switched to testing and now have two h.264 videos playing simultaneously.

One other benefit is I also now don’t get the annoying black screen for a fraction of a second each time the playlist restarts!

I am happy to stick to h.264 at the moment as that is what I get most of my content in anyway so it saves me converting it.

I do still see the occasional speeding-up of the videos when the playlist restarts, I assume that it is trying to catch-up rather than drop frames?

Thanks again.

Phil

Correct. If you play multiple videos at the same time, it might help to change the performance setting from “Power Save” to “Performance”. You can find that setting in the device configuration editor. Can you try that?

Hi Florian.

It is already set to performance. Now there are other slides being displayed before/after the video, it seems a lot better.

Thanks

Phil

I see. In that case the reason is probably that playing two videos immediately followed by two other videos results in 4 decoders being active at the same time: two from the playing video and two from being preloaded so they can start immediately once the page flips over. If all videos involved are FullHD, that can be a lot to handle for the Pi.

info-beamer - Digital Signage for the Raspberry Pi community forum - Imprint