Raspberry Pi 7” touch screen

Hello there,

I am using the official 7" raspberry screen connected to a RPi4 B. The info beamer hosted image boots up and then ends with:


[] Setting up working directories
[
] Starting

After “Starting” nothing happens for a while until the system reboots. It looks like its not switching to the real start up display where the ID is shown. I tried with the stable and the test release.

Any suggestions?

It probably still uses the HDMI output for any graphical output, not the attached LCD. Do you see anything in the device snapshot on its detail page? Or is that blank as well?

It’s not registered yet. So I should connect an HDMI device in order to register it?

Oh. Right. Didn’t think about that. If that’s possible, that’ll be great. Then once it’s connected, disconnect again see if the dashboard shows any output, despite the LCD being blank.

Did not work… LCD and HDMI show the same. It is shown:

Booting up…

[] …
[
] Starting

That’s it. Unfortunately.

Can you send the account this device is in and the device id or serial by email?

Nevermind. It’s still not added do an account, I guess. Can you instead send your own public IP (as see on ipinfo for example)? I might find it regardless.

It’s a new device without account… What do you want me to do?

Do you need a Port-Forwarding??

No. The IP should do it.

82.207.195.46
How ever this might work… :slight_smile:

Wow… It works!!! Thank you so much.

Issue was, that the Pi selected DISPMANX_ID_AUX_LCD instead of DISPMANX_ID_MAIN_LCD as the default visual output. It then only saw the displays on main_lcd and hdmi0, but skipped them due to the wrong default.

I’ve added /config/display with the value of main_lcd to force the correct output.

Fantastic work! Thanks a lot again.

Can the display be flipped 180 degrees?

Use the installed package to control that. Rotating using Raspberry Pi firmware settings is slower than that.

Is there any way to change the LCD backlight brightness?

On a “normal” rasbian you can modify /sys/class/backlight/rpi_backlight/brightness but on info-beamer there are no rpi_backlight folder present in /sys/class/

I want to adjust brightness by clock, so it’s darker at night than during the day.

It was there at some point, but is currently removed. The reason is quite complex:

On the Pi the original dispmanx mechanism of presenting content on the screen works in layers. The console framebuffer is a layer, info-beamer’s OpenGL output is a layer and any video rendered is another layer. Rendering each layer has a cost. Render too many of them and the Pi’s hardware video scaler, that composes these layers into the HDMI signal, might not be fast enough. This then results in occasional loss of the video signal. Here’s a post I made on the Raspberry Pi bug tracker 7 years ago.

So info-beamer has to minimize the number of active layers. One obvious way is to remove the console framebuffer as that’s completely unused during normal playback. Doing so on the 7" LCD display while the rpi-blacklight feature is active unfortunately also turns off the backlight. So not only is the console layer gone, but the complete output. Clearly not ideal. See also this other post.

So the options are either:

  • Don’t blank console layer and risk HDMI underruns resulting in video signal loss. But have the backlight controllable.
  • Don’t have backlight controllable and be able to blank and remove console layer.

Currently the second option is implemented but this also means the backlight isn’t controllable.

Thank you for a detailed answer. I guess I’ll just have to live with it for now. I have a raspberry pi with the official 7" touch screen showing current time, temperature (indoors & outdoors) plus a weather forecast (magicmirror2 based).

At night the backlight is just high enough to become irritating, especially at movie nights once you notice.

I’ve run plain raspberry os (raspian) where I adjusted the backlight via crontab, but eventually raspian always becomes unstable and stops working for some reason. Last time xorg just started seg faulting on startup. Using info-beamer with a browser payload takes so much less time than setting up Raspbian with chromium in kiosk mode when I eventually have to reinstall.

You didn’t mention which Pi version you use. If it happens to be a Pi4, then maybe things might work, as setting up the graphical output works a bit different there. Also the coupling of “blanking console” and “blanking backlight” might have been removed since then. I didn’t check for a while.

You can try the following: Fetch rpi-backlight.dtbo, place it in /config (not /overlay, as that get’s removed during OS upgrades) on the SD card. Then create /config/userconfig.txt with the following content:

overlay_prefix=/config/
dtoverlay=rpi-backlight

This should in theory allow the OS to load the backlight driver and add the stuff in /sys.

1 Like

Unfortunately it’s a 3B, but the tip is great if I ever upgrade.