RPI Zero 2 W Not Connecting to WiFi

I have had info-beamer running without issues on my RPI Zero W. Yesterday I received my Zero 2 W and am having issues. I finally found out that I need to run the testing release as the stable release does not contain the .dtb files for the zero 2. I noticed that the testing release does not have the .dtb file for the zero 2 w. I tried pulling it from another working build of raspberry pi OS, but it is not helping. I can get the zero 2 w to boot to the info-beamer loading screen, but it never connects to my WiFI in order to do the initial setup and configuration. Has anyone else had this problem?

The testing release has the necessary bcm2710-rpi-zero-2.dtb file and WiFi should work out of the box. Can you ensure that you’ve been using the correct install.zip file? While booting you should see the line:

[*] testing:211106-f70d4b:stable-0013 (...)

There isn’t a separate bcm2710-rpi-zero-2-w.dtb like with the first raspberry pi zero, not to mention the regular raspberry pi os? It wasn’t connecting to the WiFi, just hanging on the “Waiting for Content” screen going through a retry loop while repeatedly failing to connect to the backend. When I didn’t see the zero 2 w dtb file I figured maybe that was the issue.

And yes I see that line while booting. Everything seems to be working 100% fine other than the WiFi issue.

Interesting. For the Kernel/Firmware revision currently in use for testing a locally running Pi Zero 2’s WiFi works. It seems it only includes bcm2710-rpi-zero-2.dtb and didn’t need bcm2710-rpi-zero-2-w.dtb. That file later appeared without explanation in this commit.

Maybe there is another board revision? In the debug line

[*] testing:211106-f70d4b:stable-0013 (...) on XXXX (v7)

can you see the value of XXXX? It’s the board revision. The one that works locally for me is 902120.

I’m lost, I’m at the same rev. 902120.

Let me completely redo a setup of a Pi Zero 2 W later today or early tomorrow to confirm everything works locally. I’ll get back to you.

Thanks, I appreciate it.

I cannot reproduce the issue with my local Pi Zero 2 W. Here’s the first boot log:


WiFi works as intended. The most likely reasons are now:

  • Your WiFi configuration isn’t correct, so either /config/wireless has the wrong format or its content has a typo or similar issue.
  • You try to connect to a WiFi with an unsupported frequency/channel. For some channels a correct /config/wifi-country is required before the channel can be used. Similarly 5Ghz isn’t supported at all.

Can you check is any of that is a possible reason?

I did notice that it doesn’t show “Using WiFi” even though I set everything up they way I did with my RPI Zero W. No matter what I try the network configuration is not sticking. It says “using Ethernet” every single time.

Thanks for all of the assistance. I’m not sure exactly why but reinstalling using the img.gz file instead of just the zip file seemed to do the trick. Everything is working properly now.

Did you create the necessary /config/wireless file for WiFi yourself or did you let it generate by downloading a customized install.zip from the download page?

I tried both before attempting with the img.gz instead of the zip file. For some reason it only wants to work with the img.gz file :man_shrugging:t3: