info-beamer

RTSP display issues with Scheduled Player

Hi All. I’ve been using the Scheduled Player setup with some success to display CCTV cameras using the RTSP URL for each. It works really well, other than a lot of the time (but intermittently with each camera) vertical lines appear at the bottom of each image (see attached).

Are there any settings that can be changed to help this? Not much online, but I’ve found a few posts that suggest it could be a buffer setting?

Thanks.

Update: I have another screen running something similar (single stream and a browser), but because of it’s location it’s running on WiFi. That one works fine, so I just switched this one to WiFi and it’s much better. I wonder if it’s the additional latency and jitter on WiFi that is forcing a bigger buffer to be used? The CCTV server is on the local network, so probably next to zero latency on Ethernet, whereas there may be a few milliseconds introduced over WiFi.

I really don’t want to use this on WiFi permanently because three 1080p streams going 24x7 use a lot of bandwidth and will create unnecessary wireless congestion, so the problem still isn’t solved. Any help would be greatly appreciated.

These artifacts look a bit like packet loss. Although I’m not sure why that would happen more when using Ethernet. One option might be to artificially slow down the Ethernet connection from 1GB/s to 100MBit/s. That way the Pi is guaranteed to be fast enough to handle all incoming packets… In theory the Pi can enforce that, but currently there is no option to do that. Do you have a way to try that?

info-beamer - Digital Signage for the Raspberry Pi community forum - Imprint