info-beamer

Talks not loaded

I set up info-beamer with scheduled player and frabs import, and it all worked fine on a
Raspberry Pi 3 B, i then wanted to test performance on a Raspberry Pi Zero W,
it needs a little more time to boot, but works fine generally.

However, (and i don’t know if it even has something to do with the hardware)
the talks are not loaded, it just says “Nope. That’s it.”
and “No other talks”.

The assets are all loaded properly and the fake time is set correctly.

In general almost all setups should behave exactly the same across Pi models. Especially if no Pi4 is involved. The “Nope. That’s it” might be because you didn’t assign it a track (on the /frabs config page) and tried to display the “what’s next in this room” tile. Maybe that’s it?

I’m using the same setup on both Pis. Tracks are assigned.
I tried rebooting it several times, it worked once without consciously changing anything,
but most of the time it didn’t work.

Which setup is that? I could take a look.

The setup is in this account. Current setup is “Hall” but the problem also appears in setup “Corridor”

The Hall setup (https://info-beamer.com/setup/28063#frab) in its Rooms section only specifies a single device (Unknown device, serial 1919xxx), which the only device assigned to the setup is serial 1630xxx. Is that intentional?

This was not intentional, we tested around and forgot changing that.
However, fixing this didn’t help.

Looks like it works now? Anything left to do?

It seems it’s not working very stable. It works sometimes but sometimes not.

What does “not every stable” mean? What does “sometimes not” mean?

When you reboot the pi zero w, it sometimes needs a very long time to load the talks, and sometimes not.
Everything else is loaded much quicker, and the CPU is not at high load.

Maybe the background process fetching the schedule.xml is too fast and tries to download the file before the network is available. You should be able to check if you run

logread | grep frab: 

on the device (you can use the terminal on the device’s page if you’ve enabled that on the accounts page. It will show you the output generated by the process responsible for fetching schedule.xml and any error will show up there. On success, the retrieved schedule will end up in /space/root/frab/schedule.json. If that file is there and you still don’t see anything relevant on the screen, something is odd.

It seems the current state is indeed odd:
The snapshot shows “No more Talks :(”, but the /space/root/frab/schedule.json contains
Talk data which looks good. It seems the simulated time is not set correctly, maybe this is the reason.

Could be. That feature was always a bit odd. If you use that, you should see talks happening in the future if the rooms are configured correctly. Even if the talk is still weeks or days away. Does that work?

It works like a charm without simulated time. Thanks for your quick responses!

info-beamer - Digital Signage for the Raspberry Pi community forum - Imprint