info-beamer

Trigger Spots Offline

Hi there folks, I’m evaluating info-beamer at the moment for a POC which we want to show off next week… I was just wondering, if there exists an easy possibility to trigger content in the scheduled-player package via LAN(UDP) without internet connection.

I would appreciate any simple solution for triggering spots during a default playlist.

Each page within a playlist has an interactive button. Click that, then select “Remote Trigger” and give the trigger a unique name:

Then go to the device page, open the device configuration editor, select the “Advanced/Development” tab and enable the “Expose info-beamer port” option and click on “Apply configuration”.

image

You can then send a UDP packet with the following content to the device IP on port 4444. The example value corresponds to the trigger name set within the configuration:

root/remote/trigger:example

This will interrupt the active page and immediately jump to the configured page. This works offline, but note that an info-beamer hosted device by default isn’t offline capable. Check the “Offline support status” on the device’s page for how it will behave when offline.

I’ve already tried this with root/remote/trigger:example, and exposed the ports via the config file… maybe that was the fault :wink:
I will try again in the evening with root/trigger:example and post the result here…

Thank you for the quick reply!!

Had time to test the trigger as mentioned, but still no content change :confused:
I connected via telnet to the the device and saw the trigger pop up in the console as soon as I’ve sent the old trigger (root/remote/trigger:example). I think it is recognized but not handled properly…

You are correct. I forgot the ‘remote’ part and fixed me reply above. Your command is correct. Can you check if the trigger via the website works? On the device page there will be a button at the top for each remote trigger configured.

The trigger via device page worked perfectly fine…

Hm. That one uses the same UDP mechanism, just triggered from the device locally. So there should not be anything wrong in general. You should see the same log message when it’s triggered from the dashboard. Can you compare to make sure it’s identical to the once you manually send? Maybe there’s a trailing newline?

1 Like

You were totally right it was a trailing newline issue… echo -n or printf fixes my problem :wink:
Thank you very much for the fast support!

Glad that solved it.

In general it’s almost always easier to use the dashboard configuration UI instead of manually creating those files in /config. It’ll write the correct values and doesn’t require physically touching the SD card.

info-beamer - Digital Signage for the Raspberry Pi community forum - Imprint