info-beamer

Ultrawide 21:9 Support?

Anyone know if ultrawide monitors and creative can be supported, now that 4K is an option? Ultrawide is defined by the major monitor manufacturers as a 21:9 aspect ratio, 3840 x 1440 (WQHD). An ultrawide for signage would be awesome for many applications. Thanks!

1 Like

Good question, but I would guess so. So far I’ve only tested with 3840x2160 and FullHD, but I don’t see why a resolution between those shouldn’t be possible. The HEVC decoder is most likely able to decode that as I’ve tested it with 3840x2160 already. Anyone with a Pi4 and that kind of screen to get a definitive answer?

I played a little around getting infobeamer running on my LG display (3440x1440). I have some mixed results until now.

The full screen browser works perfect, without any adjustments. My main problem is configuring the correct screen resolution. I’m not able to get/create a working userconfig.txt for my custom HDMI output. And the the 4K option has the wrong aspect ratio and creates black bars around my images.
Can someone help me with a working configuration file?

You mean running a “Scheduled Player” based setup has black bars? What’s the resolution when you look at the properties on the device page?

image

In automode I get this resolution:

GSM-LG_ULTRAWIDE
2560x1080 60.00Hz


Correct aspect ratio, but not fullscreen.

4k I get this output

GSM-LG_ULTRAWIDE
3840x2160 30.00Hz


more or less fullscreen with wrong aspect ratio.

The shown images have exactly the size of my display (3440x1440 px). I use in my case “HD Image/Video Player”.

Fullscreen Browser looks great

GSM-LG_ULTRAWIDE
3440x1440 60.00Hz

With my custom settings in the userconfig (hdmi_cvt) the raspberry shows noting, display stays complete dark.

Which settings did you try for that? You can also use the terminal feature on the device page (if not visible, activate it on your account page. Then run tvservice -s.

Finally it’s running. Thanks for the support, sometime it helps just to explain the problem.

These are my current settings:

hdmi_group=2
hdmi_mode=87
hdmi_aspect_21_9=7
hdmi_cvt=3440 1440 60 7 0 0 1

The output if tvservice -s throws (with this configuration) an error message: [E] Failed to initialize VCHI (ret=1)

Thanks for the update and the solution. Happy to be the rubber duck :slight_smile:

info-beamer - Digital Signage for the Raspberry Pi community forum - Imprint