Won't reboot after Edit Configuration

Hi There,

I’m trying dual screen for the first time and I’m getting hung on save edit-configuration/reboot after I choose the two screen option (1 on left, 2 on right). I’m using a Pi4b, 4gig. I’ve tried the stable release, then the testing release, same hanging. Is there something about turning on developer options I’m missing? Pi is registered and “online” and I can get snapshots in “normal” mode.

Thanks for any assistance

Chris in Montreal

PS using “corporate” wifi with login page.

With “hung” you mean nothing happens on the already running Pi? Or does it reboot and then stops working?

About the WiFi: Those captive portal style networks most likely won’t work reliably. Once the Pi has to “click” something on that login page, it’s over. There isn’t a sane way to automate this in a generic way.

When I click save and reboot, the process starts but I never get a reboot. When I hover over the button, I get the black circle with a bar through it.

The problem may be with the SD card. In file manager I see two new drive letters (d: and e:) and both show 96 MB capacity - something wrong there, should say 16GB
I’ll try another SD card (formatting did not get rid of this problem) then see what’s up.

(Alex.stinton seemed to have a similar problem that was traced to a partition problem on the SD card - this supports my bad SD card theory.)

Still no love here.

I got a new 16GB SanDisk ultra. Tried and failed the normal setup (deleted existing device - did not get a new PIN). Tried custom setup (.gz file) that used Raspberry Pi Imager - copies perfectly - did not automatically add the device. I’m stuck here.

Could you check my account to see if I haven’t messed something up with testing multiple devices?

For wifi, I’ll try using my phone hotspot as a test.

This might have the same reason as this recent post: A too strict firewall that doesn’t allow the info-beamer updater access to the required server. The result is that the updater cannot function. As the updater is also used for every configuration change, the same applies to the configuration editor: Applying changes also won’t work.

That’s expected: info-beamer OS itself used the first two 96MB partitions. The third partition fills the rest of the SD card and is used for assigned data.

This too hints at a firewall/network issued. Can you check the four colored icons in the bottom right corner of the welcome screen? Are they all lit up green?

Thank-you for this. Can this be fixed with IT putting “” on a whitelist?

I have had PINs twice using this network - strange. Many more failures and endless “waiting for content.”


Have a look at Best practices for setting up an info-beamer device - info-beamer for required network access. But the recommended method is to put the devices into their own VLAN or open visitor WiFi.

Thanks again. I’ll try open visitor wifif first.

No colour on the icons

I’ve disabled my Mcafee firewall. Reboot both PC and Pi Still no luck. “Waiting for content” even though I’ve deleted the device and copied a fresh install to the micro-sd.

Update 8:25 EST

Got around the problem for now. Bought a USB-C to ethernet adapter for my pixel 4xl and now I’m connected and unloading files. Will get around to IT firewall issues later. Thank-you.

Different issues now. Will start another thread.

info-beamer - Digital Signage for the Raspberry Pi community forum - Imprint