info-beamer

Editing Device Configuration - Changes Won't Apply

I’m trying to change the config on a couple of devices.

I’ve changed the performance settings and then clicked the apply changes and reboot button. It says the device is “applying the configuration” but the device doesn’t reboot and when I reload the page the changes I’ve made have reverted to what they were before.

Am I missing a key step in making these changes?

SOLVED: the changes have now applied. I think it just needed time to apply.

On your device 11867xxxxx, the updater process shut down as it detected an inconsistency in how the SD card is partitioned. From the log:

[updater] boot disk signature: 'MSDOS5'
[updater] booting in mode . from 0
[updater] cur != boot
[updater] cannot confirm mbr sanity. updater shutting down

This is an issue I’ve seen come up rarely and I’ve do not yet fully understand how that can happen. Maybe you can help with that for that specific device? Did you by any chance remove the SD card after you initially let info-beamer run through the setup steps and put it back into a PC’s SD card reader?

Not that I’m aware, though I could well have done that as it was the first device I setup.

I think it might just have taken time for the changes to apply. Might just have been a patience thing on my part. Is it worth a format and reinstall to ensure this isn’t a problem in the future?

Ok. Guess it will remain a mystery for now :slight_smile:

If you can live with resetting that device once again, feel free to do so. The easiest way to force the device to fully rewrite its SD partition setup is to create an empty file named /config/force-reset on the SD card. When booting up the OS will detect that file and redo the initialization steps. You can then register the devices again and remove the previous version of it.

As for this observation. Let me explain why that might be the case: Changing the configuration using the Dashboard triggers the exact same process on the device that is also responsible for operating system updates. You can essentially think of those as identical:

  • An OS update rewrites a new OS version and reboots into it
  • A config update rewrites the existing OS version with modified configuration values and reboots into it.

For both cases the full operating system install.zip file (the same you can download here) has to be available on the device. When you initially set up a new device, one of the first tasks the OS does in the background is to fetch that file (it does a few optimizations so the transfer is usually only a few MB instead of the full 50MB download). This initial file transfer might take a moment. Before that’s completed the OS cannot apply configuration changes. Once the file is available, applying a configuration change usually takes around 20 seconds before the OS reboots.

I did this just to be on the safe side. Config updates are quicker now. Thanks for the assist.

I seem to have hit this problem again for two new devices. I’ve tried the force reset on them with no success.

Do you have a firewall active for those devices? It seems that sync.info-beamer.com is not reachable and runs into a timeout. Without that, changing the configuration or assigning new content isn’t possible.

In your case it seems the peer-to-peer feature still allowed two devices to retrieve the assigned content from a third local device running the same setup. Once you assign content that’s not already locally available, retrieval of new content will also fail.

This issue should also be visible while setting up the device. On the welcome screen, always make sure all four icons turn green. My guess is that at least one of them remain gray.

Thanks! That was the issue. Someone had blocked it on the firewall by mistake.

1 Like
info-beamer - Digital Signage for the Raspberry Pi community forum - Imprint