Wrong timezone in browser plugin

There are already topics about that but maybe no one (else) out there also had that issue.

Timezone setup of a device is ignored when using the Browser PlugIn.

Try it out! send Monitortafelgenerator to your desktop Browser and also put it into the Browser Plugin of your info-beamer and compare the timetable.

WTF went wrong here!?

I may apreciate your advice. Thank you creatures out there.

Unfortunately the browser plugin currently doesn’t use the timezone setting. I’ll see what’s required to get that added.

1 Like

That would be very helpful. I got the the answer from Rhein-Main-Verkehrsverbund that they are not able to change their code in the Fahrplanauskunft to force a specific timezone within the URI request.

So I may highly and kindly ask you to try to implement the recognition of the RasPi‘s OS timezone setting into this smart little browser inside info-beamer package.

Where I can spend some beverages to push it up? :grin::+1:t3:

Anyway thanks a lot in advance and I appreciate any feedback.


Hi @infobeamer-fw … any update so far? Is that too hard to implement?

No need for passive aggressive questions. The browser backend has that support since last week and the scheduled player now supports signaling the timezone to the backend. Update your scheduled player package and set the device’s timezone in the device list.

I’m sorry about that, if that’s how it was understood, like passive aggression. If there is no response at all, you don’t know if anyone will do anything or not.

Anyway, thank you for taking care of the problem and I can confirm the functioning TZ herewith.

1 Like