info-beamer

Custom Branding - missing text

When using the branding.jpg or branding.mp4 (https://info-beamer.com/doc/device-configuration#custombranding), the divice is not showing the wifi-setup information:
Annotation 2020-05-06 132504

It should show that information centered at the bottom of the screen.

Yes - but I’m not using a regular screen :wink:


Would it be possible to have “Waiting for content” blinking as standard - and also the “Connect to the new WiFi network…” on the middle of the screen somehow?

Always these special screens :slight_smile:

I can extend the existing branding.json to include an option to place the three status texts:

  • Configuration WiFi xxxxxxxx
  • Connect using PIN xxxxxx
  • Waiting for content

vertically centered instead of placing them at the bottom. A new testing release should include that tomorrow.

Cool… I had forgot the hidden branding.json feature :slight_smile:

testing is now updated. Add:

{
    "branding-action-centered": true
}

to branding.json. This will move the action message into the center of the screen.

1 Like

Is there a way to force the device to go into the “branding” mode? Or do I have to reformat the SD-card every time?

Once a setup has been assigned, the devices switches into that setup as soon as possible. There’s no mechanism to return, other than deleting the device from an account and adding it again. What you could do of course if either take the welcome screen’s source code (it’s in /hello within a running system) and convert it to a package.

1 Like

Would it be possible to:

  1. Add more information when booting: Instead of just “Waiting for content”, add e.g. “Waiting for network” etc.
  2. Make the text bigger (or make the size custom-able)?
  3. Center the text (See picture 2)
  4. Show the “Connect to the new WiFi network…to configure this device”?

Bigger tekst: (Ad. 1 + 2)
1

Centered text and missing the “Connect to” information:
2

That wouldn’t be correct. As this point the device is waiting to be assigned content. Right now there’s no extra state that would indicate that there might be a network issue other than the icons in the bottom right corner (not visible in your case).

Can do.

I’m surprised it isn’t. Will be fixed.

I guess that would also work. It’ll probably have to be part of customization options again, so the change doesn’t break any existing manuals.

1 Like

If the device haven’t got an IP address - the network must be “missing” so the device can never get any content. Just saying :wink:

Yep. That’s what the four icons in the corner are for normally. They do indicate network, DNS and NTP problems. I guess allowing them to be placed elsewhere is the next step :slight_smile:

testing has just been updated. Here’s the relevant changes:

  • The branding-action-centered text is now properly centered
  • New boolean value branding-state-centered (default false) in branding.json. It set to true, the four status icons are now also placed in the center of the screen, below the branding-action-centered text.
  • New string value branding-wifi-template (default “Configuration WiFi %s active”) in branding.json: Can be used to custom the WiFi configuration text. In your example, you’d place "Connect to the new WiFi network %s to configure this device" there.

Additionally it’s now possible to completely replace the welcome screen. Placing /config/welcome-screen.zip (maximum size 1MB) on the SD card will now instruct info-beamer OS to extract those files into /space/root instead of using the default from /hello.

For making it easier to start, the default welcome screen source code is now available on https://github.com/info-beamer/package-welcome-screen. Cloning the repository, zipping it up into welcome-screen.zip and placing that in /config on the SD card will use this version.

1 Like

This is great :star_struck:

Now I just need the text to be a little bigger :blush:

info-beamer - Digital Signage for the Raspberry Pi community forum - Imprint