info-beamer

RTSP stream (force TCP transport)

Some customers use RTSP as their streaming protocol. Sometimes this doesn’t work out of the box. The reason in multiple cases has been that RTSP uses UDP for data transport. The solution in that case has been to force using TCP instead. For that you have to change the device’s configuration as follows:

  • Go to the device detail page
  • Click Edit configuration
  • Click on the Advanced/Development tab
  • Enter the value rtsp_transport:tcp in the Custom libav options field.
  • Click on Apply configuration to save this change.
1 Like
info-beamer - Digital Signage for the Raspberry Pi community forum - Imprint